Opened 10 years ago

Closed 10 years ago

#3201 closed Bug (fixed)

[Opera] Discards entities when switchng to source view and back

Reported by: Karel Petranek Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Opera Review+ Cc:

Description

If you paste some text that contains some HTML entities (like hardbreaks  ), switch to source code view and then switch back again, you can see all the hardbreaks being replaced with nbsp text.

Attachments (2)

ckentities.png (13.3 KB) - added by Karel Petranek 10 years ago.
Screenshots of the entity bug
3201.patch (523 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Karel Petranek

Attachment: ckentities.png added

Screenshots of the entity bug

comment:1 Changed 10 years ago by Garry Yao

Keywords: Pending added

Unable to reproduce, your browser information would be a great addition.

comment:2 Changed 10 years ago by Artur Formella

comment:3 Changed 10 years ago by Karel Petranek

It is also present in the nightly build. My browser: Opera 9.64 build 10487 Windows Vista Home Premium SP1

I am pasting the test string from OpenOffice.org Writer (3.0), it looks like this before pasting: Test

Test

Test

Test

I also tried this with Google Chrome (v 1.0) and it pastes it also incorrectly - it adds some weird metadata at the top (tell me if you want a screenshot). Also the spaces were not present. This is probably for another ticket though...

comment:4 in reply to:  3 Changed 10 years ago by Garry Yao

Keywords: Confirmed Opera added; Pending removed
Milestone: CKEditor 3.0
Summary: CKEditor 3.0 discards entities when switchng to source view and back[Opera] Discards entities when switchng to source view and back

Replying to DeeCee:

It is also present in the nightly build. My browser: Opera 9.64 build 10487 Windows Vista Home Premium SP1

I am pasting the test string from OpenOffice.org Writer (3.0), it looks like this before pasting: Test

Test

Test

Test

I also tried this with Google Chrome (v 1.0) and it pastes it also incorrectly - it adds some weird metadata at the top (tell me if you want a screenshot). Also the spaces were not present. This is probably for another ticket though...

I was able to reproduce with Opera now but not Webkit, please provide a screenshot for Google Chrome 1.0.

comment:5 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 3201.patch added

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review? added

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:8 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3310]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy