Opened 11 years ago

Closed 11 years ago

#3238 closed Bug (fixed)

Dialogs open out of the window

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: UI : Dialogs Version:
Keywords: Confirmed Oracle Review+ Cc: Senthil

Description

Many times, but now always, dialogs open outside the viewport, over the top of it. I has been easily reproducible with the Link dialog.

Attachments (2)

3238.patch (3.2 KB) - added by Martin Kou 11 years ago.
3238_2.patch (3.3 KB) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by Artur Formella

Resolution: duplicate
Status: newclosed

DUP of #3258

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: closedreopened

Actually #3258 is a DUP of this one.

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Cc: Senthil added
Keywords: Oracle added

comment:4 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: reopenednew

comment:5 Changed 11 years ago by Martin Kou

Keywords: Review? added

Using offsetHeight and offsetWidth in CKEDITOR.dialog::getSize() doesn't work, because the browser often needs some time to layout the dialog correctly (especially to load the CSS file). That's the reason why previously getSize() would only return a size stored into resize().

Now we've changed the meaning of CKEDITOR.dialog::resize() to mean only the size of the content area, we can no longer simply output the size stored by resize() - there'll be some difference between the content area size and the whole dialog's size. The only place in the code that knows clearly the size of decorations put around the dialog content area is the skin. So I've added a 'getSize' event to CKEDITOR.dialog which must be handled by skin.js of any skin.

Changed 11 years ago by Martin Kou

Attachment: 3238.patch added

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Martin Kou to Frederico Caldeira Knabben

I understand you point here Martin, but this is a design flaw in the dialog system. It should be able to automatically detect the dialog size, without any (non accurate) help from the skin files.

If all we need is giving time the browser to "think" before moving the dialog, then a different solution can be found, which would not require skin hacks. I'm attaching a new patch for it.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 3238_2.patch added

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

comment:8 Changed 11 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:9 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3342].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy