Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3249 closed Bug (fixed)

'Deleted Text' Style within list item problem

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Firefox WorksForMe Cc:

Description

Reproducing Procedures

  1. Open the replace by class example page;
  2. Make the following content with the selection;
    <ol>
    	<li>
    		<p>
    			^text^</p>
    	</li>
    </ol>
    
  3. Open 'Style Combo' and select 'Deleted Text' option;
    • Expected Result :
      <ol>
      	<li>
      		<p>
      			<del>
      				text</del></p>
      	</li>
      </ol>
      
    • Actual Result:
      <ol>
      	<li>
      		<p>
      		</p>
      		<del>
      		<p>
      			text</p>
      		</del></li>
      </ol>
      

Change History (6)

comment:1 Changed 11 years ago by Garry Yao

Keywords: Firefox added

Though <del> wrapping other block elements is valid with W3C schema, Firefox doesn't show the text with correct format, so it's a FF only bug.
Since both of the following markup is valid:

<del>
<p>text</p>
</del>

AND

<p>
<del>text</del>
</p>

We could comply the latter to make Firefox right.

comment:2 Changed 11 years ago by Garry Yao

The problem was found with 'Inserted Text' style.

comment:3 Changed 11 years ago by Garry Yao

Milestone: CKEditor 3.0CKEditor 3.x

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe added

I'm not able to reproduce it with the current trunk. Can you confirm it?

comment:5 Changed 11 years ago by Garry Yao

Resolution: fixed
Status: newclosed

It's not appear anymore, probably fixed by recent changset.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.xCKEditor 3.0
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy