Opened 12 years ago

Closed 12 years ago

#326 closed Bug (fixed)

Firefox: Lists + formatted text = undesired behavior

Reported by: Brian Klug Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: WorksForMe Pending Cc:

Description

  1. Load demo page with Firefox
  1. Focus in editor, Control-A to select all, hit delete
  1. Click the "Numbered list" toolbar button
  1. Type three lines of text
  1. Hit Control-A to select all, change the font to Comic Sans
  1. Focus on item 2, and indent with the "Increase Indent" toolbar button
  1. Focus at the end of the line, and hit enter
  1. Bug 1: Notice that there is an extra newline at the end of the sublist
  1. Click the "Decrease indent" button
  1. Bug 2: The decrease indent function does not work

Note: This happens to normal lists as well, not just nested lists.

Change History (4)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe Pending added; Firefox removed

I'm not able to reproduce it. It is working as expected with FF2 and IE6.

Maybe there is some very specific way to move the cursor, or making selections, that is needed to be done to see the bug.

Can you confirm this is still a bug? Do you have more info about it?

comment:2 Changed 12 years ago by Brian Klug

I can still reproduce it at http://www.fckeditor.net/demo using FireFox 2.0.0.3.

Each mouse action is accounted for in the original report - if you still can't reproduce it using that - let me know and perhaps I'll make a video.

comment:3 Changed 12 years ago by Alfonso Martínez de Lizarrondo

The demo of 2.4.2 has the bug, but the nightly works fine, and that's where bugs should be tested because lots of things have been fixed since the last release.

comment:4 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: newclosed

Expired

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy