Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#3293 closed Bug (wontfix)

Table properties 2nd level menus do not show up in IE8 on Vista

Reported by: Tri Owned by: Martin Kou
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.4 Beta
Keywords: Confirmed IE CantFix Cc: mteper@…

Description

Second level context menus for table properties (such as Row, Cell, and Column sub-menus) do not show up in FCKEditor 2.6.4 when viewed with IE8 on Vista (both x64 and x86).

This is discussed here: http://www.fckeditor.net/forums/viewtopic.php?f=6&t=13532

Attachments (1)

FCKEditor 2.6.4. IE8 bug.jpg (36.2 KB) - added by Tri 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by Tri

comment:1 Changed 9 years ago by Tri

Cc: mteper@… added
Version: CKEditor 3.0 Beta 2

Additional info: our frustrated users discovered that repeated clicking on the Row context menu item will eventually cause the submenu to materialize. This typically takes 3-5 clicks. Any word on a fix?

comment:2 Changed 9 years ago by Artur Formella

Keywords: ie8 menu removed
Milestone: FCKeditor 2.6.5
Priority: HighNormal
Version: CKEditor 3.0 Beta 2FCKeditor 2.6.4 Beta

comment:3 Changed 8 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:4 Changed 8 years ago by Martin Kou

Keywords: Confirmed IE added

I've tested a variety of hacks yesterday and early this morning (e.g. focusing the submenu's window, creating text selection in the popup, changing CSS attributes, etc.), and none of them worked. The problem is certainly triggered by the IE7 position fix in fckpanel.js, however.

comment:5 Changed 8 years ago by Tri

Note that this problem appears to have been solved in the 3.0 RC.

comment:6 Changed 8 years ago by Martin Kou

Hmm... it seems there's no easy solution for this. I've tried a ton of ways to try to get around this but nothing worked.

The root of the problem is that Vista/IE8 is showing popups in a wrong order, yet if you click the popups the ordering is/becomes correct. So this is what happens:

  1. The first popup is shown.
  2. The second popup is shown - under the first popup.
  3. But if you click on where the second popup is, IE8 will suddenly discover the second popup should go to the top and now it shows the second popup to the top.

If I change the popup logic to show the second popup first, adjust for the first popup's location and then show the parent popup on top - it'll be wrong too. Because as soon as I click back on the first popup we'll get a wrong ordering again.

If we're to definitely fix it we'd have to abandon createPopup() and change to a complete iframe approach.

comment:7 Changed 8 years ago by Alfonso Martínez de Lizarrondo

#3981 has been marked as dup

comment:8 Changed 8 years ago by Alfonso Martínez de Lizarrondo

This is the ticket at Microsoft about the problem: https://connect.microsoft.com/IE/feedback/ViewFeedback.aspx?FeedbackID=425465

The workaround would be to add the site to the trusted zone (with protected mode disabled), or more easily, change the "Allow script-initiated windows without size or position constraints" setting to Enabled for the Internet zone, although of course this won't be possible in many corporate environments.

comment:9 Changed 8 years ago by Frederico Caldeira Knabben

Ok... thanks to the (as usual) wonderful help of Alfonso, we have preciselly individuated the culprit here: Windows Vista/7 + IE8 + Protected Mode + All default settings.

The workaround proposed by Alfonso helps with it, but of course it's not a definitive solution. I'm now able to reproduce it, so I'll try finding a solution for it, if any.

Fortunately CKEditor uses a different panel system for IE, and this is not an issue with it, so we have a good option.

comment:10 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: CantFix added
Milestone: FCKeditor 2.6.5
Resolution: wontfix
Status: assignedclosed

I'm afraid we'll not be able to fix it for FCKeditor. This is a browser intrinsic bug, and we're not finding any way to workaround it.

For those with urgent needs for this fix, Alfonso's workaround is an option, or even better upgrading to CKEditor 3.

comment:11 Changed 8 years ago by Tri

Is there an ETA for CKEditor.NET?

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy