Opened 9 years ago

Closed 9 years ago

#3300 closed Bug (fixed)

Styles are not being applied correctly

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: Core : Styles Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

  1. Load a sample.
  2. Select "some sample".
  3. Apply the "Strike Through" style.

Result: only "some " get styled.

Attachments (1)

3300.patch (628 bytes) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

It looks like this issue has been introduced with [3333]. The style plugin TCs are failing after that.

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 3300.patch added

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Owner: set to Frederico Caldeira Knabben
Status: newassigned

The problem here is the small fix in range.js introduced with [3333], which is correct, but the style system was counting with that bug to work properly.

Fortunately the fix in the style system is also simple. Patch attached.

comment:3 Changed 9 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3353].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy