Opened 10 years ago

Closed 10 years ago

#3317 closed Bug (worksforme)

Create a line break in the Message Body when creating an E-Mail Link Type

Reported by: Oscar Bautista Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: General Version: FCKeditor 2.6.3 Beta
Keywords: WorksForMe Pending Cc:

Description

I am using version 2.6.3 Beta of FCKeditor. The problem we are having is seen when creating an E-Mail Link Type. The message body does not allow me to insert a carriage return or line break. The link only works when there are no "hard" carriage returns. I have tried <br>, <p>, /n, <li>, etc. Nothing seems to work. How do I allow the message body to allow line breaks.

The email client on the computer does come up, but I need to allow the line breaks in the message body.

We are using FCKeditor on a .Net site.

Thanks

Change History (4)

comment:1 Changed 10 years ago by Artur Formella

Keywords: WorksForMe Pending added; Line Break using E-Mail Link Type removed

I was unable to reproduce this bug. Could you provide more information (i.e. browser)?

Could you also try it with nightly build? http://www.fckeditor.net/nightly/fckeditor/_samples/default.html

comment:2 in reply to:  1 ; Changed 10 years ago by Oscar Bautista

Not sure what you mean by trying nightly build.

To recreate, I am using version 2.6.3 beta. I have tried using IE7 and Firefox 3.1. Same problem on both. Let's say we type the word "american" in the Fckeditor window, highlight the word, and click on the "Insert/Edit Link" icon on the tool bar. This will open the Link window. Select "E-Mail" in the Link Type dropdown list. Type E-Mail address, Message Subject, and Message Body. In the Message Body try typing with the following format (note each word is on a different line):

Test1: Test2: Test3:

The error that IE returns is this: "Line: 1 Char: 187 Error: Unterminated string constant Code0"

If I put all the words on the same line it works. The link opens the email client. I need to include the line breaks.

Thanks

comment:3 in reply to:  2 Changed 10 years ago by Oscar Bautista

Just realized the comment I just submitted didnt include the breaks I need.

I need Test1:, Test2:, and Test3 to be in separate lines in the Message Body.

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Resolution: worksforme
Status: newclosed

I've verified that it works correctly.

Please upgrade your version of FCKeditor.

Remember also that sending a mail is a job between your browser and your mail client, so there are sometimes troubles when you try to use anything beyond a mail address, and we can't do anything about that.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy