Opened 10 years ago

Closed 10 years ago

#3324 closed Task (fixed)

Update V3 Test Case

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: QA Version:
Keywords: Confirmed Review+ Cc:

Description

Agile ticket for updating TCs for CKEDITOR.dom.documentFragment regard recent changes.

Attachments (3)

3324.patch (1.1 KB) - added by Garry Yao 10 years ago.
3324_2.patch (4.2 KB) - added by Garry Yao 10 years ago.
3324_3.patch (4.2 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Garry Yao

Attachment: 3324.patch added

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

The patch makes it pass on FF, but not in IE.

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added
Status: newassigned

The reason of failure is because IE itself has certain treatment for empty nodes;

  1. It doesn't preserve any '\n' within the text at all. ( '\t' depends on position, see next )
  2. It preserve '\t' depends on the position of occurence, leading '\t' will be trimmed too.

Changed 10 years ago by Garry Yao

Attachment: 3324_2.patch added

comment:3 Changed 10 years ago by Garry Yao

Component: GeneralQA

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

The test_trim_ie is failing

Changed 10 years ago by Garry Yao

Attachment: 3324_3.patch added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:6 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3490].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy