Opened 10 years ago

Closed 10 years ago

#3338 closed Bug (fixed)

mouse cursor over input field shows as arrow instead of beam

Reported by: Alfonso Martínez de Lizarrondo Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

Tested Firefox 3.1 and IE8, open any dialog and move the mouse over an <input type="text">

The cursor remains as an arrow, it isn't clear that the user can type there.

The cursor should have changed to the "beam" indicating that it's an active text input.

The problem is due to the reset.css file.

Attachments (4)

3338.patch (716 bytes) - added by Artur Formella 10 years ago.
3338_2.patch (1.0 KB) - added by Artur Formella 10 years ago.
3338_3.patch (2.1 KB) - added by Frederico Caldeira Knabben 10 years ago.
3338_4.patch (3.4 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed added

This one should be fixed with #3180.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

No, this has nothing to do with #3180.

comment:3 Changed 10 years ago by Artur Formella

Owner: set to Artur Formella
Status: newassigned

Changed 10 years ago by Artur Formella

Attachment: 3338.patch added

comment:4 Changed 10 years ago by Artur Formella

Keywords: Review? added

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The correct fix should be in the reset.css file. Instead of setting the cursor to "default", we should use "auto" there. Then, if anything in the editor needs a specific cursor, it should define it by itself.

Changed 10 years ago by Artur Formella

Attachment: 3338_2.patch added

comment:6 Changed 10 years ago by Artur Formella

Keywords: Review? added; Review- removed

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Artur Formella to Frederico Caldeira Knabben
Status: assignednew

Ok, it looks like "auto" works well for IE, but not FF. In any case, it's a good thing to have, so other things, like anchors, will have their correct cursors automatically.

The cursor definitions are ok for input and textarea. The only thins is that the dialog buttons got the "text" cursor after the patch, so they need to be fixed also.

I'm taking over the ticket so we can quickly close it.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 3338_3.patch added

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

comment:9 Changed 10 years ago by Artur Formella

I'm not sure if this is the right way. Insert in source mode:

<input type="text">

Move the cursor over the input. It isn't clear that the user can't type there.

comment:10 Changed 10 years ago by Martin Kou

I'm proposing a new patch, because the previous patch is still wrong in the following cases:

  1. If I move my mouse cursor over a checkbox, I'm getting the beam cursor.
  2. If I move my mouse cursor over a disabled textbox, I'm also getting a beam cursor.

I've also found the issue where "cursor: auto" is interpreted as the default arrow cursor for text inputs is specific to Firefox - IE, Safari and Opera correctly interpreted that as the beam cursor.

So the new patch would apply the beam cursor only for non-disabled text inputs. And if required, it would apply the style only to Gecko based browsers.

Changed 10 years ago by Martin Kou

Attachment: 3338_4.patch added

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed
Owner: changed from Frederico Caldeira Knabben to Martin Kou
Status: assignednew

comment:12 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [3464].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy