Opened 8 years ago

Closed 8 years ago

#3387 closed Bug (fixed)

Layout consistence and stability

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

The current editor layout is still unstable. The elements path resizes when switching to source view, or en using the editor in IE. Also, the editor height changes when switching to source. We must achieve a consistent and stable layout.

Attachments (1)

3387.patch (7.2 KB) - added by Frederico Caldeira Knabben 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Frederico Caldeira Knabben

Attachment: 3387.patch added

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Status: newassigned

In effect we need to find the final DOM structure that represents the editor. I've spend a lot of time on trying to achieve the perfect solution for it. The main problem here is the editor height representation. In V2, the height is set to the size of the entire editor structure. This was easy to control and achieve, because we where running the editor inside a well controlled (quirks mode) iframe. But in V3 the editor runs in the containing page, and we have no control of it at all. So, the structure must work on all browsers, in all modes.

I was almost able to reproduce the V2 behavior, but I've faced limitations with IE and Opera. I've posted the details of it at our forums. But, no lucky here. A different solution had to be taken.

As a pure CSS solution is not feasible, I've considered a JavaScript driven solution. But here again we have problems for several reasons as the editor structure is created even before its CSS is ready (which changes sizes once applied), as well as problems to proper adjust the sizes at runtime when having the the top and bottom spaces changing their sizes dynamically.

So, the one and only possibility left was making the height setting being applied to the contents area only, instead of the entire editor structure (which instead still takes the width). It means that we are not anymore able to support percent heights :(.

The patch introduces the new structural changes, as well as small fixes to the elements path bar.

comment:2 Changed 8 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3400].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy