Opened 11 years ago

Closed 10 years ago

#3460 closed Bug (expired)

Incorrect HTML escaping only in Safari

Reported by: eunice Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Pending Cc:

Description

The greater sign (">"), it is not correctly HTML escaped in safari. Strangly, "<" is escaped correctly.

Change History (4)

comment:1 Changed 11 years ago by eunice

To be precise, I reproduced this error on

Safari Version 3.2.1 (5525.27.1) OSX 10.5.6

FCKeditor 2.6.4

comment:2 Changed 11 years ago by eunice

Version: FCKeditor 2.6.4

Also, in all Versions (even CKEditor Beta), hitting "Bold", "Italic" and then start typing doesn't work.

However, if you select the text and hit "bold", "italic" after typing it functions properly.

comment:3 in reply to:  2 Changed 11 years ago by Artur Formella

Keywords: Pending added

Replying to eunice:

Also, in all Versions (even CKEditor Beta), hitting "Bold", "Italic" and then start typing doesn't work.

However, if you select the text and hit "bold", "italic" after typing it functions properly.

Please open new ticket for second issue.

I was not able to reproduce the main bug in Safari 4.

It can be connected with #2333 so please try nightly build:

http://www.fckeditor.net/nightly/fckeditor/_samples/default.html

comment:4 Changed 10 years ago by Artur Formella

Resolution: expired
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy