Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#3481 closed Bug (fixed)

paste error IN Chrome

Reported by: toby941 Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.5
Component: General Version: FCKeditor 2.6.4
Keywords: Confirmed WebKit Review+ Cc: toby941@…

Description (last modified by Martin Kou)

  1. use chrome(version:1.0.154.36) 2.create a table
  2. paste something into table
  3. the format of the table is error

Attachments (3)

fck.jpg (25.4 KB) - added by toby941 9 years ago.
the error format
3481.patch (2.4 KB) - added by Martin Kou 8 years ago.
3481_2.patch (2.5 KB) - added by Martin Kou 8 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 9 years ago by toby941

Cc: toby941@… added

comment:2 Changed 9 years ago by Artur Formella

Keywords: WorksForMe Pending added

I was unable to reproduce this bug on http://www.fckeditor.net/demo.

Could you tell me what did you paste?

comment:3 Changed 9 years ago by toby941

I use Chrome(2.0.168.0),on[ http://www.fckeditor.net/demo.] # click the insert table button,insert a table(default attribute ) # copy two letters,and then paste some times,the table format was break

Changed 9 years ago by toby941

Attachment: fck.jpg added

the error format

comment:4 Changed 8 years ago by Martin Kou

Description: modified (diff)

Tidied up the description.

comment:5 Changed 8 years ago by Martin Kou

Resolution: worksforme
Status: newclosed

I'm not able to reproduce the bug as well. Closing as worksforme.

comment:6 Changed 8 years ago by Martin Kou

Keywords: Confirmed Chrome added; WorksForMe Pending removed
Resolution: worksforme
Status: closedreopened

Oh, I've just got the bug reproduced.

comment:7 Changed 8 years ago by Martin Kou

To reliably reproduce this bug:

  1. Open http://www.fckeditor.net/demo in Chome 2.
  2. Create a default table.
  3. Copy two letters from anywhere.
  4. Put caret to a table cell.
  5. Press Ctrl-V twice or more times.

The first Ctrl-V works, the second, third, ... Ctrl-V will paste the two letters outside of table cells.

comment:8 Changed 8 years ago by Martin Kou

Keywords: WebKit added; Chrome removed

The same bug can also be reproduced in Safari 4 in Mac.

Changed 8 years ago by Martin Kou

Attachment: 3481.patch added

comment:9 Changed 8 years ago by Martin Kou

Keywords: Review? added

comment:10 Changed 8 years ago by Martin Kou

Owner: set to Martin Kou
Status: reopenednew

comment:11 Changed 8 years ago by Martin Kou

Status: newassigned

comment:12 Changed 8 years ago by Garry Yao

Keywords: Review- added; Review? removed

When you looked into the DOM after pasted:

		<td><span class="Apple-style-span"
				   style="-webkit-border-horizontal-spacing: 0px; -webkit-border-vertical-spacing: 0px; ">sa</span>{ZWNBSP}
		</td>

You'll notice that the second ZWNBSP is still there, the removing of this node has failed, don't know why.

Changed 8 years ago by Martin Kou

Attachment: 3481_2.patch added

comment:13 Changed 8 years ago by Martin Kou

Keywords: Review? added; Review- removed

Something in the browser's paste logic seems to be merging the text nodes, and even worse, even if I use inline tags like <b> and <span> it would get merged too. I've found that Safari doesn't merge <a> tags but it would still clone it (i.e. the original DOM node reference we've got becomes invalid). So I've assigned an id to the <a> dummy to keep track of it.

comment:14 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:15 Changed 8 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3973].

Click here for more info about our SVN system.

comment:16 Changed 8 years ago by Alfonso Martínez de Lizarrondo

This patch created #4960

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy