Opened 10 years ago

Closed 7 years ago

#3499 closed Bug (duplicate)

Error when using tablecommands plugin and claiming focus before fckeditor has completed loading

Reported by: Eddie Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi,

I am using v2.6.4 (but this problem was also present in previous releases).

When i enable the tablecommands plugin and include the required buttons in the toolbarset i'm getting a JS error when clicking on another input field in the form before FCKeditor has completed loading (because of a non-caching browser and/or slow connection).

The annoying thing about this error is that FCKeditor continues to work but when you submit the data, the data you first put into the editor is being submitted and not the changed (edit) data.

The problem is IE(7/8) related (firefox works fine). IE8 tells me that the error is in:

/fckeditor/editor/js/fckeditorcode_ie.js line: 66 char: 429

Which leads to:

/fckeditor/editor/_source/internals/fcktablehandler_ie.js line: 51 col: 5

I can 'fix' the problem in 2 ways:

  • Remove both the 'TableMergeCells' and 'TableHorizontalSplitCell' from the toolbarset (all other table related buttons can stay).
  • Put FCK.Focus(); in the beginning of the FCKTableHandler.GetSelectedCells function so that FCKeditor always has focus, but this is cleary not a solution.

Reproduce by:

  • using the asp version (JS version on a local drive works to fast)
  • enable tablecommands plugin and add tablebuttons in toolbarset
  • add an input field above FCKeditor inside the form
  • Load the page preferrably from an external server with a non-caching browser (so you have time to click on the input field before FCKeditor has finished loading).

Change History (1)

comment:1 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

DUP of #2893

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy