Opened 10 years ago

Closed 10 years ago

#3535 closed Bug (fixed)

IE: The context menu rapidly flashes at the left of the document when opening

Reported by: Frederico Caldeira Knabben Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Context Menu Version:
Keywords: Confirmed IE Review+ Cc:

Description

In IE, when showing a context menu panel, it rapidly flashes at the the very left of the document (in the correct Y position though) and them moves the the right place.

Attachments (2)

3535.patch (717 bytes) - added by Artur Formella 10 years ago.
3535_2.patch (478 bytes) - added by Tobiasz Cudnik 10 years ago.
Tested in FF3, IE8.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Artur Formella

Attachment: 3535.patch added

comment:2 Changed 10 years ago by Artur Formella

Oh. sorry :)

Changed 10 years ago by Tobiasz Cudnik

Attachment: 3535_2.patch added

Tested in FF3, IE8.

comment:3 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review? added

Since i've used another approach i'm attaching my patch also. Will check yours.

This issue has been introduced in [3305].

comment:4 Changed 10 years ago by Tobiasz Cudnik

After checking Arczi's patch i must say i would prefer this way, but i'm affraid that this wont work with RTL, because of "display: none" elements doesn't provide offsetWidth, which is used on L160 of unpatched source.

comment:5 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3514].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy