Opened 11 years ago

Closed 11 years ago

#3547 closed Bug (duplicate)

Compare versions shows changes that were not made by user

Reported by: Steve Organ Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5 Beta
Keywords: Cc:

Description

Compare versions feature is showing a lot of changes at the bottom of their document that were not made and shouldn't be there.

The issue can be reproduced by pasting in the source of the original document (using the "source" button in FCK editor), then simply editing, saving, and publishing that document without changing the content. It appears that simply loading some documents in the FCK editor modifies their contents.

Steps to reproduce:

1) create new content with Rich Text editor. In the rich editor, click on the source button to edit the document source, erase any contents, and paste in the contents from before.txt (attached). 2) save and publish the document. 3) edit the document created in step 1. Do not change any content. 4) save and publish the document. 5) click on the info tab in the document box in the right column. Click on "Compare Versions". Even though no changes were made, the source was modified. A large block of invalid changes are marked at the bottom of the document.

Attachments (1)

before.txt (10.8 KB) - added by Steve Organ 11 years ago.
Test content

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by Steve Organ

Attachment: before.txt added

Test content

comment:1 Changed 11 years ago by Artur Formella

Keywords: Comparisons Compare Versioning removed
Resolution: duplicate
Status: newclosed

It is a duplicate of #1810

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy