Opened 10 years ago

Closed 10 years ago

#3619 closed New Feature (fixed)

Add IDs to the table caption and summary fields

Reported by: Josh Nisly Owned by: Artur Formella
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: hasPatch Confirmed Review+ Cc:

Description

CKEditor allows setting the caption and summary for a table. Since these properties do not have an equivalent in many document formats, it would be nice to make so that these options can be hidden. I have attached a patch which implements this.

Attachments (3)

3619.patch (15.9 KB) - added by Josh Nisly 10 years ago.
3619_2.patch (639 bytes) - added by Josh Nisly 10 years ago.
3619_3.patch (663 bytes) - added by Artur Formella 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Josh Nisly

Attachment: 3619.patch added

comment:1 Changed 10 years ago by Artur Formella

Keywords: hasPatch Confirmed added; HasPatch removed
Milestone: CKEditor 3.x
Summary: Make table caption and summary configurableHidden dialog elements

The patch is ok but I think we need a system solution for all other elements and tabs.

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

I though that the api_dialog sample already shows how to modify the default dialogs without needing to add options for every possible configuration need.

comment:3 Changed 10 years ago by Josh Nisly

Keywords: hasPatch removed
Summary: Hidden dialog elementsAdd IDs to the table caption and summary fields

You are absolutely right! Thanks for pointing that out. There is still some change required, though, because currently the caption and summary elements don't have ids. I'll submit a patch for that shortly

Changed 10 years ago by Josh Nisly

Attachment: 3619_2.patch added

comment:4 Changed 10 years ago by Josh Nisly

Keywords: hasPatch added

Changed 10 years ago by Artur Formella

Attachment: 3619_3.patch added

comment:5 Changed 10 years ago by Artur Formella

Keywords: Review? added
Milestone: CKEditor 3.xCKEditor 3.0
Owner: set to Artur Formella
Status: newassigned

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Artur Formella

Resolution: fixed
Status: assignedclosed

Fixed with [3574]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy