Opened 10 years ago

Closed 8 years ago

#3625 closed New Feature (invalid)

Enhanced Internal Link Search for Mediawiki+FCKeditor

Reported by: Don Stringham Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: HasPatch Cc:

Description

The users of the FamilySearch Research Wiki (http://wiki.familysearch.org) needed to have the FCKeditor internal link search return the same results as if search from our main page. Attached are two patches one for FCKeditorSajax.body.php which adds two functions and one for FCKeditor.php which adds a few constants. Then by setting two global variables in LocalSettings.php ($wgFCKeditorSearch and $wgFCKeditorSearchType) you can have the FCKeditor internal link search use the same search engine as is Mediawiki or continue to use the default FCKeditor link search. At this time we have not yet implemented the patches on our production system but they are running on our testing and staging environments.

Attachments (3)

FCKeditor.php.patch (8.2 KB) - added by Don Stringham 10 years ago.
Added constants to this file to help with settings in LocalSettings.php
FCKeditorSajax.body.php.patch (12.1 KB) - added by Don Stringham 10 years ago.
Added two functions and additional logic to use different search mechanisms with FCKeditor+Mediawiki
FCKeditor.Sajax.body.php.2.patch (1.2 KB) - added by Don Stringham 10 years ago.
Added logic to handle Lucene 2.1 search.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Don Stringham

Attachment: FCKeditor.php.patch added

Added constants to this file to help with settings in LocalSettings.php

Changed 10 years ago by Don Stringham

Added two functions and additional logic to use different search mechanisms with FCKeditor+Mediawiki

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed HasPatch added

Changed 10 years ago by Don Stringham

Added logic to handle Lucene 2.1 search.

comment:2 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy