Opened 10 years ago

Closed 10 years ago

#3676 closed Bug (invalid)

FCKeditor 2.6.4 save didn't work with Chrome 3.0

Reported by: Patrice De Saint Steban Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.5
Component: Core : Output Data Version: FCKeditor 2.6.4
Keywords: Confirmed WorksForMe Pending Cc:

Description

With the last chrome version : (3.0.183.3) when I submit a form, the fckeditor (2.6.4) didn't copy the html to the textarea.

With the console, I have this error :

Uncaught TypeError: Cannot read property 'parentNode' of null fckeditorcode_gecko.js:35

The problem didn't appear in fckeditor 3.0b2

Change History (6)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added
Priority: NormalHigh

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:3 Changed 10 years ago by Martin Kou

Keywords: Pending added

I've tested the submit feature in http://www.fckeditor.net/demo with Chrome 3.0.190.4 - the first submit works, but subsequent submits do not work, and there's no JavaScript error.

It seems to be a bug in Chrome 3 regarding forms with target="_blank", though. Because I can reproduce the same issue with a target="_blank" form that does not contain FCKeditor.

comment:4 Changed 10 years ago by Martin Kou

Keywords: WorksForMe added

comment:5 Changed 10 years ago by Patrice De Saint Steban

Effectively, its seem that the chrome bug was corrected with the 3.0.190.4 version. It's now work on my project. I not use a target="_blank".

Thank to work on it.

comment:6 Changed 10 years ago by Martin Kou

Resolution: invalid
Status: assignedclosed

Ok. This is actually a Chrome bug and it's fixed already. So I'm closing this as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy