Opened 11 years ago

Closed 11 years ago

#3679 closed Bug (fixed)

[IE8] element.html test fails in various places

Reported by: Tobiasz Cudnik Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IE Confirmed Review+ Cc:

Description (last modified by Tobiasz Cudnik)

Depending on chosen mode on IE8, element.html test fails in various places. This patch seems to fix it, but it uses too many workarounds and need to be rewritten. It should use less workarounds as possible, mostly on IE8 strict.

Attachments (1)

3679.patch (2.3 KB) - added by Tobiasz Cudnik 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:2 Changed 11 years ago by Tobiasz Cudnik

Description: modified (diff)

comment:3 Changed 11 years ago by Garry Yao

The correct fix would fall into setAttribute/removeAttribute, and addClass/removeClass just use the former under the hood.

Changed 11 years ago by Tobiasz Cudnik

Attachment: 3679.patch added

comment:4 Changed 11 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:5 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review? removed

There's still a minor problem for 'test_setAttribute2, test_setAttributes, test_getAttribute_ignoreExpandoAttributes' to pass on IE8 strict because of style text formatting problem:

*Expected:

float: right;

*Actual:

FLOAT:RIGHT

But as discussed with Tobias, we'll open a new ticket for this.

comment:6 Changed 11 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Issue mentioned by Garry has been moved to #3693.

This issue is fixed with [3644].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy