Opened 10 years ago

Closed 10 years ago

#3714 closed Bug (invalid)

Tables are causing html parser to go into infinite loop

Reported by: Martin Kou Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: Core : Output Data Version: SVN (CKEditor) - OLD
Keywords: Cc:

Description

To reproduce:

  1. Open replacebyclass.html in any browser.
  2. Insert a default table into the editing area.
  3. Switch to Source mode.
  4. The editor hangs.

Change History (4)

comment:1 Changed 10 years ago by Martin Kou

There seems to be some randomness in this bug - I'm not always able to reproduce it.

comment:2 Changed 10 years ago by Martin Kou

Ok, I've got a reliable way to reproduce this bug:

  1. Insert a table after the first paragraph.
  2. Delete any other paragraphs in the editor by selecting them and pressing backspace twice.
  3. Go to Source mode.
  4. The browser hangs.

comment:3 Changed 10 years ago by Martin Kou

This bug seems to be introduced by [3642].

comment:4 Changed 10 years ago by Martin Kou

Resolution: invalid
Status: newclosed

Oops... so it's already fixed by [3663]... I was just one revision behind the fix :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy