Opened 8 years ago

Closed 8 years ago

#3727 closed Bug (fixed)

Cell Properties dialog missing color selection option

Reported by: Damian Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description

The cell border & background color options in the Cell Properties dialog do not provide an easy way for users to select colors.

FCKEditor 2.6 provides a color selector in this case.

Attachments (2)

3727.patch (70.7 KB) - added by Tobiasz Cudnik 8 years ago.
3727_2.patch (70.7 KB) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by Tobiasz Cudnik

Keywords: Confirmed added
Owner: set to Tobiasz Cudnik
Status: newassigned

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

We're not able to have this feature for the 3.0.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3727.patch added

comment:3 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

Patch reproduces color picker for table cells from FCKeditor. Most of old dialog's code had been reused.

Everything seems to work fine, but i have some doubts regarding cell property dialog layout. Right now it mimics V2 one, but it has some issues (check IE quirks) caused by new buttons. I'm proposing relocating them below text field.

comment:4 Changed 8 years ago by Garry Yao

Keywords: Review- added; Review? removed

The patch is almost good for me, except:

  1. The color dialog matrix doesn't work in safari.
  2. Coding styles should be changed when migrating codes from v2.

comment:5 Changed 8 years ago by Garry Yao

While it's always safe and prior to align with v2 features, I would vote for using float panel for this feature as Tobias mentioned, we could consider it after this got fixed.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3727_2.patch added

comment:6 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

Next patch fixes Safari 3 issue, which seems to have limit for table markup (?!), because it works with 3/4 of color table, but not with the whole one.

That's why i've delegated mouseover and click event handlers to table root, which reduced the markup and allowed safari3 to work.

I don't have this issue on safari4 (4.0 530.17 win).

comment:7 Changed 8 years ago by Garry Yao

Keywords: Review+ added; Review? removed

The 'borderColor' attribute doesn't work for none-IE, please open a dedicated ticket for it as soon as this get closed.

comment:8 Changed 8 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [4185].

borderColor issue is available as #4368.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy