Opened 10 years ago

Closed 10 years ago

#3729 closed Bug (invalid)

IE8 Javascript Random Errors

Reported by: Oscar Bautista Owned by:
Priority: Normal Milestone: FCKeditor 2.6.5
Component: General Version: FCKeditor 2.6.4
Keywords: Confirmed IE8 Cc: oscar.bautista@…, al.connelly@…

Description

We started receiving random errors that I believe are related to IE8. Below are the errors being generated. Can you help resolve them? We are using version 2.6.3 Beta - Build 19726 in a .Net environment. Fckeditor works okay in FireFox and Chrome.


Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729) Timestamp: Mon, 15 Jun 2009 15:06:21 UTC

Message: 'FCKeditorAPI.GetInstance(...)' is null or not an object Line: 116 Char: 81 Code: 0 URI: https://chapters.acg.org/admin/content/edit.aspx?PageId=5445


Line: 116 Error: 'FCKeditorAPI.GetInstance(...)' is null or not an object

FCKeditorAPI.GetInstance('mCT_Main_12_1_Content_fckContent_ccEditor').UpdateLinkedField();


Line: 5 Error: Object required

sd[w]=function(e){qm_kille(e)};

Change History (5)

comment:1 Changed 10 years ago by Artur Formella

Priority: HighNormal

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Component: Server : ASP.NetGeneral
Milestone: FCKeditor 2.6.5

This is not likely to be related to the server side integration. We'll be working on IE8 for the 2.6.5, so we'll check it at that point.

comment:3 Changed 10 years ago by Al C

Cc: al.connelly@… added
Version: FCKeditor 2.6.3 BetaFCKeditor 2.6.4

comment:4 Changed 10 years ago by Martin Kou

Keywords: Confirmed IE8 added

I've got an email from the reporters about the reproduction procedures, and I've confirmed the problem on their site.

comment:5 Changed 10 years ago by Martin Kou

Resolution: invalid
Status: newclosed

I've found some major problems with the test page:

  1. The FCKUpdateLinkedField() function is getting called more and more if you click on the pen button repeatedly.
  2. The page tries to initialize editor instances with the same name repeatedly.

I've also noticed that the error message only appears after the first time the button is clicked, and so it should be related to the logical bug from within the page.

So it seems to be this isn't a bug on our side. Closing ticket as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy