Opened 10 years ago

Closed 10 years ago

#3740 closed Bug (fixed)

[IE] Paste from Word does not paste on last cursor location

Reported by: Damian Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed IBM Review+ Cc:

Description

When using Paste from Word, the result is pasted at the beginning of the document instead of where the cursor was when the dialog was invoked.

Works as expected in FF.

Attachments (1)

3740.patch (967 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed added
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 10 years ago by Garry Yao

Keywords: Discussion added

After some investigation, the bug is quite obscure, I think it's because of CKEDITOR.dom.range::select on a collapsed range, the native selection is lost after this statement:

	// Remove our temporary stuff.
	this.document.$.selection.clear();

Because I can make it works without it by manually remove the nodes inside, but the cursor doesn't blink.
Here I'll be asking for discussion:

  1. Is there any clue to resolve this?
  2. Can we workaround it by adapting the way proposed by #3707?

Changed 10 years ago by Garry Yao

Attachment: 3740.patch added

comment:3 Changed 10 years ago by Garry Yao

Keywords: Review? added; Discussion removed

Martin's revealed the reason behind this bug to me that dear 'contentEditable' has been turned off during the dialog life cycle for good of JAWS visual cursor mode, so the workaround could be let the insertion happened right after the closing.

comment:4 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:5 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3686].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy