Opened 10 years ago

Closed 10 years ago

#3745 closed Bug (invalid)

[FF3] Problem with pasting content from ODS file into rich text area

Reported by: Damian Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Cc:

Description

When pasting a simple table from an ODP file into the content area of the editor the following exception is thrown in FF3:

Permission denied to get property XULElement.accessibleType
[Break on this error] });}var E=c||b.safari?B:C;E.on('blur',fu...{var n=this._.styleStateChangeCallbacks;

Attachments (1)

Test Spreadsheet.ods (9.7 KB) - added by Damian 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Damian

Attachment: Test Spreadsheet.ods added

comment:1 Changed 10 years ago by Damian

Summary: [FF3] Problem with pasting content from ODP file into rich text area[FF3] Problem with pasting content from ODS file into rich text area

Meant ODS not ODP

comment:2 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:3 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending added

I can't reproduce this issue, attached spreadsheet is pasted correctly.

I've checked on following configurations:

  • FF3, OO-3.1, linux / source, release
  • FF3, OO-3.0, winxp / source
  • FF3, OO-2.4, winxp / source, release

Can you please make a test on clean FF profile, without any addons to narrow the possibilities ?

comment:4 Changed 10 years ago by Damian

I couldn't reproduce this on a clean FF3 profile.

comment:5 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending removed
Resolution: invalid
Status: assignedclosed

My tests wasn't done using clean profile so it seem that some FF addons collision is present in your configuration. You can easily check this by binary search thou disabling addons.

Please reopen this ticket if you will find some informations in this matter related to CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy