Opened 8 years ago

Closed 8 years ago

#3764 closed Bug (fixed)

Show Blocks + setData causes blocks refresh problem

Reported by: Damian Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description

When setData is called on the editor while show blocks is enabled, the block indicators are not refreshed properly.

Attached example test.

To reproduce:

  1. Open attached sample
  2. When editor ready, press Set Data.
  3. Enable Show Blocks
  4. Change the text in the edit area and press Set Data again

Results:
Show Blocks is still active on toolbar but block indicators are no longer rendered properly.

Attachments (3)

blocksSample.html (1.3 KB) - added by Damian 8 years ago.
3764.patch (865 bytes) - added by Tobiasz Cudnik 8 years ago.
3764_2.patch (854 bytes) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by Damian

Attachment: blocksSample.html added

comment:1 Changed 8 years ago by Tobiasz Cudnik

Keywords: Confirmed added
Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3764.patch added

comment:2 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

Patch handles also new page command.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

It looks like we don't need the on('mode') code anymore at this point.

Also, please preserve the code style. It's just a matter of maintaining the style we can see in the statements a few lines above the patch changes.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 3764_2.patch added

comment:4 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

comment:5 Changed 8 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:6 Changed 8 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [3699].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy