Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3802 closed Bug (fixed)

SCAYT plugin causes IE6 to hang with 100% CPU usage.

Reported by: Martin Kou Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Spell Checker Version: SVN (CKEditor) - OLD
Keywords: Review+ 3.0RC Cc: WebSpellChecker.net

Description

To reproduce:

  1. Enable SCAYT in IE6.
  2. Type anything in the editing area - with a purposefully misspelled word to check for the plugin's effectiveness.
  3. Wait a few seconds.
  4. Now your IE6 freezes up with 100% CPU usage.
  5. If it didn't freeze up in step 4, wait for your misspelled word to get highlighted, and right click on it - it should freeze up here.

Screencast: http://screencast.com/t/WAwTDfj9R

Attachments (2)

3802.patch (587 bytes) - added by Martin Kou 10 years ago.
3802_2.patch (2.3 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net added

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 10 years ago by Martin Kou

Attachment: 3802.patch added

comment:3 Changed 10 years ago by Martin Kou

Keywords: Review? added

Since we're going to release a beta really soon, we can't go on to fix this completely. Other tests have shown the bug to occur in IE7 and IE8 as well.

So I'm disabling it for all IE versions at the moment.

comment:4 Changed 10 years ago by Martin Kou

Keywords: 3.0RC added

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Martin Kou to Frederico Caldeira Knabben
Status: assignednew

Hey Martin... stay calm and breath... let's have a less hacky solution to disable it. I'm attaching a new patch.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 3802_2.patch added

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed

comment:7 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [3738].

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

I'm able to reproduce it by following the exact steps shown on Martin's screencast.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy