Opened 10 years ago

Closed 10 years ago

#3807 closed Bug (fixed)

[IE]Block style broken when cursor on front of text

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: Core : Styles Version:
Keywords: IBM Confirmed Cc: damian.chojna@…

Description

Reproducing Procedures

  1. Open the replace by class example page in IE;
  2. Load eidtor with the following content and selection;
    <p>paragraph</p>
    ^text
    
  3. Click on any block style, e.g. 'Numbered List';
    • Actual Result:
      <ol>
      	<li>
      		paragraph</li>
      </ol>
      ^text
      

Attachments (2)

3807.patch (1.3 KB) - added by Garry Yao 10 years ago.
3807_2.patch (1.8 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed added
Owner: set to Garry Yao
Priority: NormalHigh
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 3807.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added

Actually I has wrong the domiterator from the title, it's an implicit bug of IE selection system, because when we make the selection as described above, you can figure out from the elementpath that the selection is instead inside above paragraph.
We need a fix for the selection system.

comment:3 Changed 10 years ago by Garry Yao

Summary: [IE]domiterator broken with enterMode = BR[IE]Block style broken when cursor on front of text

Update ticket summary, it's not dedicate to br entermode anymore.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Priority: HighNormal

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
  • We should not throw the error in the selection change check function. There could be unknown selection issues, and we must avoid them breaking the editor code at that point, considering that this function is executed hundreds of times during the editor life cycle.
  • The checkSelectionChange looks like the wrong place for this fix. The problem is with the selection class itself, within the getRanges function probably.
  • The changelog is missing.

Changed 10 years ago by Garry Yao

Attachment: 3807_2.patch added

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:7 Changed 10 years ago by Damian

Cc: damian.chojna@… added
Keywords: IBM added

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

comment:9 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending added

I could not reproduce this issue on newest trunk using on any IE. After trying revision [3772] i was able to get JS error in IE 6 and 7 (although different then described in ticket description).

Maybe this fix is not necessary due to other changes ?

comment:10 Changed 10 years ago by Garry Yao

Keywords: Review? Pending removed
Resolution: fixed
Status: assignedclosed

Unable to reproduce this bug anymore on trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy