Opened 10 years ago

Closed 10 years ago

#3810 closed Bug (fixed)

IE: Template throws error

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE Review? WorksForMe Cc:

Description

With IE, a js error is thrown when using the Template button, after selecting one of the templates.

Attachments (1)

3810.patch (1.9 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Problem comes from 'CKEDITOR.editor::setData'.

Changed 10 years ago by Garry Yao

Attachment: 3810.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added

Again, coz CKEDITOR.editor::setData is sync, unlock selection ( invoked in dialog.hide ) for IE will result in error, the only event we can relay on now is contentDom, so I make the changes to template plugin.
Then, I found the editor is still not gaining focus within the event handler, and that's because contentDom is fired too early to gain document focus.( Focus is locked by 'isLoadingData')Ok, so let's make the event happened later, result in such a ugly fix.

comment:3 Changed 10 years ago by Artur Formella

Keywords: WorksForMe added

This bug seems to be fixed with [3794]

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Yes, it's not anymore an issue with the current trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy