Opened 6 years ago

Closed 6 years ago

Last modified 19 months ago

#3828 closed New Feature (fixed)

Paste from Word - bullets not reproduced

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: Plugin : Paste from Word Version:
Keywords: IBM Confirmed Paste Review+ Cc:

Description

When using Paste from Word dialog to paste a bullet list with indented bullet items the list is not preserved correctly. It appears that that sub lists are actually created as separate lists.

Use attached sample Word document to reproduce.

Attachments (2)

TestList.doc (23.5 KB) - added by damo 6 years ago.
3828.patch (2.7 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by damo

comment:1 Changed 6 years ago by garry.yao

  • Keywords Discussion added
  • Type changed from Bug to New Feature

Currently we don't support mso-list in our paste from word function, so it's a feature.

comment:2 Changed 6 years ago by fredck

  • Keywords Confirmed added; Discussion removed
  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

We're not supposed to have changes to the paster from Words features. We have enhancements planned for the 3.1, and we could consider this one at that point.

comment:3 Changed 6 years ago by garry.yao

  • Keywords Paste added
  • Owner set to garry.yao
  • Status changed from new to assigned

The list in the attachment doc is representing the following HTML( which is surprising, since we normally don't expect an output with correct html list tags ):

<ul style="margin-top: 0cm;" type="disc">
	<li class="MsoNormal" style=""><span lang="EN-IE">Sdfd</span></li>
	<ul style="margin-top: 0cm;" type="circle">
		<li class="MsoNormal" style=""><span lang="EN-IE">This line is indented bullets</span>
		</li>
		<ul style="margin-top: 0cm;" type="square">
			<li class="MsoNormal" style=""><span lang="EN-IE">And this line is indented again</span>
			</li>
		</ul>
	</ul>
</ul>

It would be helpful if you could give me some clue on how this doc is produced( was unable to create a list manually in MS-Word version 2003/2007 which output the same markup as it )? Or it's been generated( Convert from some other application format)?

In any case, we'll probably target cleanup to this as a more generic html cleanup( <ul>s should not be nested ) instead of a MS-Word only cleanup.

comment:4 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Changes are committed with [4312] and [4313] at pasting branch.

comment:5 Changed 6 years ago by garry.yao

  • Resolution fixed deleted
  • Status changed from closed to reopened

After a discussion, this particular fixing should be present as a core fixing at the parser level, makes it more generic.

comment:6 Changed 6 years ago by garry.yao

  • Keywords Review? added

Changed 6 years ago by garry.yao

comment:7 Changed 6 years ago by garry.yao

  • Milestone changed from CKEditor 3.1 to CKEditor 3.0.1

comment:8 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:9 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixing with [4320] at trunk and reverting invalid pasting branch changes with [4321].

comment:10 Changed 19 months ago by fredck

  • Component changed from General to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy