Opened 10 years ago

Closed 10 years ago

#3875 closed Bug (fixed)

[Safari] Context menu for cells not complete

Reported by: Damian Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description

To reproduce:

  1. Open nightly Ajax sample
  2. Insert a table
  3. Right click in an empty cell

Result: Context menu contains the following options

  • Cut / Copy / Paste
  • Delete Table
  • Table properties

Missing: Cell, Row, Column menus

This also occurs for cells that have content but where the user right clicks outside of the text in the cell.

Safari 3.2.2 on WinXP

Attachments (2)

3875.patch (914 bytes) - added by Martin Kou 10 years ago.
3875_2.patch (908 bytes) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed added

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:3 Changed 10 years ago by Martin Kou

This is a regression caused by [3792].

Changed 10 years ago by Martin Kou

Attachment: 3875.patch added

comment:4 Changed 10 years ago by Martin Kou

Keywords: Review? added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review- added; Review? removed

Even the hasTableTag checking is not necessary.

Changed 10 years ago by Martin Kou

Attachment: 3875_2.patch added

comment:6 Changed 10 years ago by Martin Kou

Keywords: Review? added; Review- removed

comment:7 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:8 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3826].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy