Opened 10 years ago

Closed 10 years ago

#3928 closed Bug (fixed)

Link plugin badly broken - <a> have incorrect href attribute

Reported by: Neil Jenkins Owned by: Garry Yao
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description (last modified by Frederico Caldeira Knabben)

Steps to reproduce.

  1. Type some text.
  2. Select some and click the link button
  3. Enter a valid URL
  4. Call editor.getData() or look at source

The URL instead of "http://www.foo.com" is set to "javascript:void(0/*###*/"

Verified on the latest SVN revision (3855) on Mac OS X 10.5 with Firefox 3.5 and Safari 4.0.2

Attachments (1)

3928.patch (4.3 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Neil Jenkins

Summary: Link dialog produces incorrect href attributesLink plugin badly broken - <a> have incorrect href attribute

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Version: SVN (CKEditor)

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.0
Priority: NormalHigh

comment:4 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 3928.patch added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review? added

I'm taking over this ticket since it's emergent.

comment:6 Changed 10 years ago by Garry Yao

Owner: changed from Tobiasz Cudnik to Garry Yao
Status: assignednew

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Please add the changelog on commit.

comment:8 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: newclosed

Fixed with [3864].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy