Opened 12 years ago

Closed 12 years ago

#394 closed Bug (worksforme)

another bug in the solved bug #318: Multiple linked images are getting merged in a single

Reported by: robert Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: Pending Cc:

Description

hi, try a different scenario, try to insert a link from the image property then press ok.

ex: insert image-->browse server -->u choose an image -->click on the link tag -->specify a URL -->press the OK , u have an linked image then insert another image with a link with the same way

result:(in ie the link of the first image will disappear and the second image conserve its link -- in mozilla ff the the first image takes the link of the second-->the first and the second image have the same link)

Change History (4)

comment:1 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added; link removed

I can't reproduce the problem in IE using the trunk, and the problem in Firefox is the same than #393, after inserting the second image, that image is already inside the previous link, so when you try to set the second link, in fact you're changing the link that holds both images.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

This ticket has expired. Please reopen it if necessary.

comment:3 Changed 12 years ago by hoffmandirt

Resolution: worksforme
Status: closedreopened

I am running into this same bug. I just downloaded the 2.4.2 source code. All that I changed in fckconfig.js is FCKConfig.EnterMode to "br". When a user or myself try to insert multiple images and give these images links, the image link of the last image inserted surrounds all of the images, thus all images now have the same link associated with them. This does not happen if one image is inserted at a time and then separated from the next by a space or return. I am using ColdFusion MX 6.1. Bug found with IE6. This works correctly with Firefox 2.

comment:4 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Resolution: worksforme
Status: reopenedclosed

The fix for #318 isn't available in 2.4.2.
Use a nightly to test the code

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy