Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#3959 closed Bug (fixed)

[FF] Pasting content from Word causes problems

Reported by: Damian Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: Plugin : Paste from Word Version: 3.0 RC
Keywords: Firefox Confirmed IBM Review+ Cc:

Description

When pasting content from a Word document that happens to have a date field the content styles are displayed incorrectly. The height of the text is incorrect and results in excessive overlapping (see attached example).

Also, the table in the provided word document is removed.

The incorrect font styles and the removed table issue only occur in FF. IE is working well.

To reproduce:

  1. Open a nightly sample
  2. Copy the whole contents of the Test_doc_with_date.doc
  3. Use paste from Word dialog to paste the whole contents with default settings

Using the same document with the date field removed fixes the style issue (see Test_doc_without_date.doc), although the table is still removed.

Pasting directly into the content area preserves the table.

Attachments (5)

Test_doc_with_date.doc (103.5 KB) - added by Damian 10 years ago.
ExampleWithDateField.png (271.2 KB) - added by Damian 10 years ago.
Test_doc_without_date.doc (103.0 KB) - added by Damian 10 years ago.
3959.patch (1.1 KB) - added by Garry Yao 10 years ago.
3959_2.patch (1.5 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Damian

Attachment: Test_doc_with_date.doc added

Changed 10 years ago by Damian

Attachment: ExampleWithDateField.png added

Changed 10 years ago by Damian

Attachment: Test_doc_without_date.doc added

comment:1 Changed 10 years ago by Garry Yao

Keywords: Firefox Confirmed added
Owner: set to Garry Yao
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 3959.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added

The following MS-Word content which cause the problem, where the single-quote is not processed correctly by the cleaner.

<span style='mso-element:field-separator'>

comment:3 Changed 10 years ago by Garry Yao

Keywords: Review- added; Review? removed

The previous fixing is incorrect, since it's the single-quote within IE conditional comments which cause the problem, double-quote is guaranteed outside.

<!--[if supportFields]>
<span style='mso-element:field-separator'>
<![endif]-->

Changed 10 years ago by Garry Yao

Attachment: 3959_2.patch added

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed
Milestone: CKEditor 3.0

comment:6 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3929].

comment:7 Changed 5 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy