Opened 12 years ago

Closed 12 years ago

#396 closed Bug (fixed)

Can't create linked image in Opera

Reported by: Alfonso Martínez de Lizarrondo Owned by: Hallvord R. M. Steen (Opera Software)
Priority: Normal Milestone: Opera Compatibility
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description

Put a image in the body (for example a smiley), now try to link it to a url, it fails.

It also fails if it's done using the image dialog and the second tab to put a url (this time the dialog won't close as the FCK.CreateLink is returning null and the code doesn't expect that problem).

Change History (6)

comment:1 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Seems to work for me in both 9.2 and internal 9.5. Please explain steps to reproduce in more detail!

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Using the trunk

  1. Put the cursor at the end of the test line.
  2. Press the insert image dialog, put anything in the url field, go to the second tab to add the link and put again anything there.
  3. Press OK: dialog doesn't close
JavaScript - http://localhost/FCKDev/editor/fckdialog.html
Event thread: click
Error:
Unhandled exception: [Object InternalException]
code: 6
message: WRONG_ARGUMENTS_ERR
Backtrace:
  Line 84 of linked script http://localhost/FCKDev/editor/_source/internals/fckselection_gecko.js
    oRange.selectNode(element);
  Line 256 of linked script http://localhost/FCKDev/editor/dialog/fck_image/fck_image.js
    oEditor.FCKSelection.SelectNode(oLink);
  Line 85 of inline#1 script in http://localhost/FCKDev/editor/fckdialog.html
    if (window.frames["frmMain"].Ok && window.frames["frmMain"].Ok())
      Line 1 of  script 
    Ok();
  At unknown location
    [statement source code not available]

comment:3 Changed 12 years ago by Kaare Byberg

This has been reported as Opera bug 262283.

comment:4 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

comment:5 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

still a problem. Reporting new bug 271711 since the old one is fixed - it really is, so there must be more problems lurking here.

comment:6 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

It works for me with Opera build 9660.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy