Opened 10 years ago

Closed 10 years ago

#4036 closed Bug (wontfix)

[IE] Insert select control is causing error

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Styles Version:
Keywords: IE Confirmed Cc:

Description

Reproducing Procedures

  1. Open the 'replace by class' sample page.
  2. Put the cursor among text;
  3. Insert a select control;
    • Actual Result: Javascript error.

Attachments (1)

4036.patch (1.3 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Priority: NormalHigh
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 4036.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added

Fix the incomplete unlocking of IE selection.

comment:3 Changed 10 years ago by Garry Yao

Keywords: Confirmed added

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Priority: HighNormal

The change looks wrong, as there is no tneed to restore the selection, because there where no changes at all while the dialog has been opened.

Other than that, these changes broke the insertion. For example, the smilieys dialog is not anymore inserting the images in the proper place. You can try it by placing the cursor inside the "using" word and then inserting a smiley.

As a last note... I'm not able to reproduce this issue at all, at least with IE7.

comment:5 Changed 10 years ago by Garry Yao

Keywords: Pending added; Confirmed Review- removed

Attracting others to reproduce.

comment:6 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending removed

I can confirm JS error using IE7 on selection/plugin.js L500, related to nodeValue. Select control have to be inserted between text (there's no error at end of line).

comment:7 Changed 10 years ago by Artur Formella

Keywords: Confirmed added

Confirmed. IE 6.0.280

JS error:

nodeValue.length is empty

comment:8 Changed 10 years ago by Garry Yao

Resolution: wontfix
Status: assignedclosed

This's actually a IE7 selection system bug, if you're asking IE to select the Select element of the below content:

select<select></select>element<a href="#">bug</a>

with the following way:

ieNativeRange.moveToElementText( selectElement );

will result a range actually on the <a> element, proved by checking the native range content:

ieNativeRange.textHtml //<a href="#"></a>

Ridiculous indeed, the range text will become the following element's content.
The bug is not happened to IE8, and doesn't happen to other element as I can tell, so I'm proposing not providing fix at all.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy