Opened 8 years ago

Closed 7 years ago

#4072 closed Bug (fixed)

Cannot enter text below the horizontal line using Webkit

Reported by: Damian Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version:
Keywords: IBM Confirmed Safari Review+ Cc:

Description

CK Editor does not allow entering text below the horizontal line created by the "Insert Horizontal Line" toolbar icon. This appears to be for Safari, only.

Steps to reproduce:

  1. Mac 10.5.7, Safari 4.0.2
  2. Go to CK Editor nightly build => check the demos => Create and destroy editor instances for Ajax applications
  3. Place the cursor in the CK Editor text area
  4. Type some text
  5. Click on the Insert Horizontal Line toolbar icon; a horizontal line is placed after the text
  6. Move the cursor below the horizontal line and start typing text

Expected result:
The typed text is below the horizontal line

Actual result:
The text is placed above the horizontal line

Attachments (1)

4072.patch (469 bytes) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by Artur Formella

Keywords: Webkit Confirmed added
Summary: Cannot enter text below the horizontal line using SafariCannot enter text below the horizontal line using Webkit

I was able to confirm this bug using page break.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Webkit removed
Milestone: CKEditor 3.xCKEditor 3.3

I can confirm this issue with FF also.

comment:3 Changed 7 years ago by Garry Yao

Keywords: Safari added
Owner: set to Garry Yao
Status: newassigned

I can confirm this issue with FF also.

Works for me in FF and IE, though the cursor display position is shifted off to the left corner.

Changed 7 years ago by Garry Yao

Attachment: 4072.patch added

comment:4 Changed 7 years ago by Garry Yao

Keywords: Review? added

Regression of [4734].

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:6 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5276].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy