Opened 8 years ago

Closed 8 years ago

#4107 closed Bug (fixed)

Font combo inconsistency

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: Core : Styles Version:
Keywords: Confirmed Review+ Cc:

Description (last modified by Garry Yao)

Reproducing Procedures

  1. Open the 'replace by class' sample page in Firefox;
  2. Assign 'Georgia' font to word 'This';
  3. Open the 'replace by class' sample page in IE7;
  4. Copy the source of editor from FF into IE;
  5. Click inside word 'This';
    • Actual Result: The 'Font' combo is not updated.
    • Expected Result: The 'Font' combo is populated with 'Georgia'.

Attachments (2)

4107.patch (2.6 KB) - added by Garry Yao 8 years ago.
4107_2.patch (1.5 KB) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by Garry Yao

Keywords: Confirmed added
Owner: set to Garry Yao
Status: newassigned

Changed 8 years ago by Garry Yao

Attachment: 4107.patch added

comment:2 Changed 8 years ago by Garry Yao

Keywords: Review? added

Caused by font style text various in format:

font-family: Georgia,serif

vs

font-family: georgia, serif

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Milestone: CKEditor 3.0CKEditor 3.1

I understand the generalization here, but this is supposed to be a localized issue, exclusive to the fonts combo (we'll rarely have it elsewhere), so the fix could go directly to that combo code.

Also, that regex can be simplified, if we're simply looking for replacing spaces after the commas.

Changed 8 years ago by Garry Yao

Attachment: 4107_2.patch added

comment:4 Changed 8 years ago by Garry Yao

Description: modified (diff)
Keywords: Review? added; Review- removed

Update the description for accurate reproducing.

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

On commit, please:

  • Move the test to the new proper location.
  • Add the changelog entry for it.

comment:6 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [4318].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy