Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4111 closed Bug (fixed)

JS error while applying style

Reported by: Artur Formella Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Styles Version:
Keywords: Firefox Confirmed Review+ Cc:

Description

Steps to reproduce:

  • Open 'replacebyclass'
  • Select all text using mouse
  • Click Bold
  • Click Bold one more time
  • Select "Heading 1" from Format combo

Result:

node is null
http://localhost/edytor/CKEditor/trunk/_source/core/dom/range.js
Line 1369

anonymous()range.js (line 1369)
anonymous()range.js (line 1574)
anonymous()plugin.js (line 75)
applyBlockStyle()plugin.js (line 680)
anonymous()plugin.js (line 130)
applyStyle()plugin.js (line 1200)
anonymous()plugin.js (line 115)
anonymous()plugin.js (line 58)
anonymous()plugin.js (line 257)
anonymous()plugin.js (line 65)
anonymous()tools.js (line 505)
anonymous()tools.js (line 512)

It is not an regression.

Attachments (2)

4111.patch (1.8 KB) - added by Garry Yao 10 years ago.
4111_2.patch (1.8 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Firefox Confirmed added
Owner: set to Garry Yao
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 4111.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The new "marker" variable may not always exist and a new error now happens. Because of this, the new line 502 must look like:

marker && marker.remove();

Changed 10 years ago by Garry Yao

Attachment: 4111_2.patch added

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

:/

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with #3977.

comment:7 in reply to:  6 Changed 10 years ago by Garry Yao

Replying to garry.yao:

Fixed with #3977.

Typo: Fixed with [3977].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy