Opened 10 years ago

Closed 10 years ago

#4149 closed Bug (fixed)

Fix for core/editor test case

Reported by: Artur Formella Owned by: Artur Formella
Priority: Normal Milestone: CKEditor 3.0
Component: QA Version:
Keywords: Review+ Cc:

Description

test_config_inpage from core/editor.html fails because of SCAYT plugin:

beforeInit : function( editor )
{
	// Register own rbc menu group.
	editor.config.menu_groups = 'scayt_suggest,scayt_moresuggest,scayt_control,' + editor.config.menu_groups;
},

Sometimes it works because of the random loading order. My idea is to disable this plugin in config.

Test case:

http://nightly.ckeditor.com/latest/ckeditor/_tests/core/editor.html

Attachments (2)

4149.patch (393 bytes) - added by Artur Formella 10 years ago.
4149_2.patch (515 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Artur Formella

Owner: set to Artur Formella
Status: newassigned

Changed 10 years ago by Artur Formella

Attachment: 4149.patch added

comment:2 Changed 10 years ago by Artur Formella

Keywords: Review? added

comment:3 Changed 10 years ago by Artur Formella

Easy to reproduce in FF3 with enabled cache.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

I'm not able to reproduce it with FF3. It's not passing in IE7 though, but the patch is not fixing it, and it's actually making another tc to fail.

Other than that, as a side note, for such kinds of changes it's always good to add a comment explaining the reason for such thing in the code, possibly including the ticket number. In this way we understand why the scayt plugin is being removed.

Changed 10 years ago by Garry Yao

Attachment: 4149_2.patch added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

We should temporarily disable SCAYT for the whole test suite.

comment:6 Changed 10 years ago by Tobiasz Cudnik

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [4029].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy