Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#415 closed Bug (fixed)

.NET Connector could not run in medium trust.

Reported by: Robert Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor.Net 2.5
Component: Server : ASP.Net Version:
Keywords: Confirmed Cc:

Description

Dear Fred,

Is had an issue of the .Net connector not being able to run in medium trust in my .Net 2.0 environment. There for I downloaded your sourcefiles in order to be able to debug my situation.

I also converted the project to VS2005/.NET 2.0.

I made a minor change to FileWorkerBase.UserFilesDirectory() (one Configuration import, and hostingenvironment.Mappath)

And a major change to Util.CreateDirectory(path) You created the directory by recursively searching for a parent directory and then creating the child directories one by one by using an imported (Com?) dell. I circumvented this method and just called the createdirectory method, of which I know it can create nested directories at a time), and now it works.

Maybe I made your code less generic, but now it works on my host. Hope I've been a bit of help,

best regards,

Robert Sirre

Attachments (1)

FredCK.FCKeditorV2.zip (26.1 KB) - added by Robert 13 years ago.
VS2005 solution

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by Robert

Attachment: FredCK.FCKeditorV2.zip added

VS2005 solution

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: FCKeditor.Net 2.3

Thanks Robert. Actually the DLL solution is still needed because of limits of Directory.CreateDirectory(). But you are right, we should at least try (catch) to use Directory.CreateDirectory, and if it throws and error, then use the _mkdir function.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [1174].

We're now using Create() by default, and failing back to mkdir if we have problems with it.

I haven't implemented the proposed changes to FileWorkerBase as those are not related to this ticket. Also, they break compatibility with .Net 1.1, and should not bring any issues over .Net 2.0. Can you confirm it RobertSirre?

comment:3 Changed 12 years ago by Robert

Yes I can, works like a charm.

Wow it took me about one and a half hour to get into subversion again; get a Visual Studio subversion client, download the project, check out the changes in the sourcecode, build it, find me a test platform. Then the actual test took about 5 seconds :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy