Opened 10 years ago

Closed 9 years ago

#4154 closed Bug (fixed)

Real descriptions must be set into CKEDITOR.config.smiley_descriptions

Reported by: Frederico Caldeira Knabben Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.2
Component: Accessibility Version: SVN (CKEditor) - OLD
Keywords: IBM Confirmed Cc: jkavanag@…

Description

The smiley_descriptions setting currently has just a few descriptions, and all of them are textual smileys, instead of real descriptions.

Change History (6)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1CKEditor 3.2

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

#4644 has been marked as DUP.

comment:3 Changed 9 years ago by Joe Kavanagh

Cc: jkavanag@… added
Component: GeneralAccessibility
Keywords: IBM added

Screen reading software needs a description that will convey the emotion to the user.

comment:4 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Emotion icon text descriptions should be introduced in language files.
Changes are checked in with [4996] on aria branch.

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

The fact is that the smileys are content related, not UI related. So, if you're writing in English with a Chinese interface, the smileys should still output in English.

Other than that, the smileys are configuration options and we can't assume they will match the language file order.

Because of the above things, we should still provide the smiley descriptions as configuration options in English. In this way, it's still possible to localize it to specific languages at developer side.

comment:6 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5092] in 3.2.x branch.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy