Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4167 closed Task (fixed)

Remove the API docs from the release

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

The current API docs makes the release size much bigger. We're currently talking about 11MB+ uncompressed, and 1MB compressed. And it's still quite uncomplete. So, it would be better to remove it from the distribution, having it online somewhere and even downloadable.

This change would also help having the docs updated, so we can improve them even after the release.

At the same time, we need to have a script that updates the API docs daily, so all these changes must come together to be able to close this ticket.

Attachments (1)

4167.patch (1.9 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 4167.patch added

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Status: newassigned

Additionally, the _docs folder will be removed.

comment:2 Changed 10 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

In ckreleaser.release, the '_docs/api' entry can be removed from the "ignore" array as well because the _docs folder will be removed.

comment:3 in reply to:  2 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Replying to wwalc:

In ckreleaser.release, the '_docs/api' entry can be removed from the "ignore" array as well because the _docs folder will be removed.

Strangely, I was not able to find the svn:ignore for _docs/api. It should be directly on _docs, but we're now removing it. It should not be an issue so.

Fixed with [4040].

comment:4 Changed 10 years ago by Wiktor Walc

Removed _docs/api entry from ckreleaser.release file with [4041].

comment:5 in reply to:  4 Changed 10 years ago by Frederico Caldeira Knabben

Replying to wwalc:

Removed _docs/api entry from ckreleaser.release file with [4041].

Opss... it looks like we were talking about completely different things :)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy