Ticket #4184 (closed Bug: invalid)

Opened 5 years ago

Last modified 2 years ago

Images are always inserted in the beginning of the document in IE

Reported by: Cic Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.4
Keywords: Cc:

Description

Steps to reproduce (in IE 7 and 8):

  • Open an arbitrary document
  • Move down the cursor some lines
  • Press "Insert/Edit Image"
  • Insert an arbitrary image, it will now be inserted in the beginning of the document

I don't know what is causing this, but the ie-image-fix patch fixes it (afaict), however: I don't know why it fixes it (awesome, huh?). (I guess something happens to the FCK object between the Ajax call and the image insertion in IE?)

Attachments

ie-image-fix.patch (940 bytes) - added by Cic 5 years ago.

Change History

Changed 5 years ago by Cic

comment:1 Changed 5 years ago by cwilliams

Using the latest nightly I am experiencing this problem. Unfortunately, the attached patch does not fix the problem for me in IE7 or IE8.

comment:2 Changed 4 years ago by cneubauer

In image.html, before this stuff:

if ( !bHasImage ) 
	oImage = FCK.CreateElement( 'IMG' ) ;

Add these lines:

if (oEditor.FCKBrowserInfo.IsIE) {
	window.focus() ;
	FCK.Selection.Restore() ;
}

comment:3 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to invalid

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy