Opened 10 years ago

Closed 9 years ago

#4202 closed Bug (fixed)

[Safari] Enter key incorrect with enterMode = BR

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: Project : CKPackager Version: 3.2.1
Keywords: Confirmed Review+ Cc: conradchu@…, audrey@…, Alfonso Martínez de Lizarrondo

Description

Reproducing Environment

  • Safari4
  • EnterMode = BR

Two enter keystrokes are needed to create a new line in enterMode=BR.

Attachments (1)

4202.patch (1.1 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

comment:2 Changed 10 years ago by Garry Yao

Resolution: invalid
Status: newclosed

Unable to reproduce this bug anymore ( on Safari 4.0.3/Webkit 531.9.1 ) on trunk.

comment:3 Changed 9 years ago by Conrad Chu

Resolution: invalid
Status: closedreopened

I'm on Safari 4.0.3 and have been able to reproduce this on the nightly build (REV 4448).

The difference is when the editor has content pre-populated in it (via setData method) it works. But, if it's a new instance with no content, then the bug emerges.

In the latter situation, the <br> requires two hits, and it is outputting as <br></br>

Kinda of a painful bug, making the editor very difficult to use for my users.

comment:4 Changed 9 years ago by Conrad Chu

Cc: conradchu@… added

comment:5 Changed 9 years ago by Garry Yao

Keywords: Pending added

Still unable to reproduce with Safari 4.0.3 on Win, could anyone please provide an procedure?

comment:6 Changed 9 years ago by Garry Yao

Priority: HighNormal

comment:7 Changed 9 years ago by Conrad Chu

Sounds like potentially this is a Safari for Mac issue. I will try to troubleshoot.

comment:8 Changed 9 years ago by Garry Yao

Milestone: CKEditor 3.1CKEditor 3.2

comment:9 Changed 9 years ago by Garry Yao

Milestone: CKEditor 3.2

I was unable to reproduce anymore on Win.

comment:10 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: reopenedclosed

WFM also.

comment:11 Changed 9 years ago by Audrey

Resolution: worksforme
Status: closedreopened

I recently upgraded to ckeditor 3.2.1 and we are using enter mode = BR and I can reproduce this problem on Safari 4.0.5 running on snow leapord. My users reported this and it is quite frustrating for them.

The steps to recreate are similar to above, this is a field that is initially empty (there is no data). Then you type something, like "this is a new sentence" and press enter and the cursor stays put. Interestingly, if I view source at that moment a <br/> character has been added. Only when I press enter again does the cursor go to the new line and now if I view source there is a break at the end of the first line and a break *after* my cursor on the new line as well.

comment:12 Changed 9 years ago by Audrey

Version: 3.2.1

comment:13 Changed 9 years ago by Conrad Chu

I was unable to reproduce this bug on Chrome 5.0.374.29 beta running on Snow Leopard. I figured I test this on another Webkit browser to see.

However, I was able to reproduce this using Safari 4.0.5 on Snow Leopard. So perhaps it's not a webkit thing as it's a Safari issue. Perhaps user agent catch that shouldn't be applied?

comment:14 Changed 9 years ago by Audrey

Cc: audrey@… added
Keywords: Confirmed added; Pending removed

comment:15 Changed 9 years ago by Garry Yao

Cc: Alfonso Martínez de Lizarrondo added

Changed 9 years ago by Garry Yao

Attachment: 4202.patch added

comment:16 Changed 9 years ago by Garry Yao

Component: UI : Enter KeyProject : CKPackager
Keywords: Review? added

Regression of [5268], actually a typo when fixing #5212.

comment:17 Changed 9 years ago by Garry Yao

Keywords: Review? removed

comment:18 Changed 9 years ago by Garry Yao

Keywords: Review? added

comment:19 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed
Milestone: CKEditor 3.3

comment:20 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: reopenedclosed

Fixed with [5489].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy