Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4219 closed Bug (fixed)

Fallback mechanism needed for config.language

Reported by: Damian Owned by: Tobiasz Cudnik
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description

A typical use case for setting the language of the editor is to use the browser's preferred setting on the request. Sometimes the value of the language may be incompatible with the supported languages because a different country code is used. E.g. "en-ie".

When an incompatible language is set via config.language the editor should use the same mechanism it does for auto-detected languages and attempt to match the language to a compatible one by stripping out the country code.

Attachments (2)

4219.patch (1.5 KB) - added by Tobiasz Cudnik 10 years ago.
4219_2.patch (1.7 KB) - added by Tobiasz Cudnik 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Tobiasz Cudnik

Owner: set to Tobiasz Cudnik
Status: newassigned

comment:2 Changed 10 years ago by Tobiasz Cudnik

Keywords: Confirmed Review? added

TC is already available in _tests/tt/4219/4219.html.

Changed 10 years ago by Tobiasz Cudnik

Attachment: 4219.patch added

Changed 10 years ago by Tobiasz Cudnik

Attachment: 4219_2.patch added

comment:3 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

Please include the changelog when commiting.

comment:4 Changed 10 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [4135] and [4136].

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

It looks like [4135] was not a good change: #4270

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy