Opened 10 years ago

Closed 6 years ago

#4229 closed New Feature (fixed)

CSS selector support for Test Environment

Reported by: Tobiasz Cudnik Owned by:
Priority: Normal Milestone:
Component: QA Version:
Keywords: Discussion Cc:

Description

CSS selector support for Test Environment would bring us such benefits for node-related TCs:

  • shorter, leaner, more readable TCs
  • less time needed to implement a TC
  • more general node-access code formulas (possibly reusable)

"Node-related" TCs means any operation which operates on specific nodes (in both forms - as plain text and DOM representations) which are placed in larger set of other nodes. This can include things like:

  • click specific button
  • check if results inside editor is the desired one
  • add new markup in specific place

Possible solutions for this could be provided by:

One popular selector benchmark is slickspeed (although speed isn't out concern).

I think that most important factors when making a decision are (for us):

  • size of additional code
  • stability across all browser (including IE6) in dangerous TC environment
  • support level

Change History (5)

comment:1 Changed 10 years ago by Tobiasz Cudnik

Keywords: Discussion added

Let's discuss some details here. When would be the best place for hooking it up ? CKEDITOR.tests.cssSelect() or maybe add it directly to CKEDITOR.dom.document and CKEDITOR.dom.element objects (in test env only) ?

comment:2 Changed 10 years ago by Garry Yao

YUI selector has already been added into the yui test with #3040, so I think it's enough for just using it with a wrapper.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralQA
Milestone: CKEditor 3.1CKEditor 3.x

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed, because we dropped IE7 support and can use querySelector methods.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy