Opened 8 years ago

Closed 8 years ago

#4237 closed Bug (fixed)

CKEditor's ToolBar is chopped off in Safari browser 3.x

Reported by: Senthil Owned by: Tobiasz Cudnik
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.1
Component: UI : Toolbar Version:
Keywords: Confirmed HasTest Oracle Webkit Review+ Cc: Senthil

Description

Attached the sample html and config.js file to reproduce the issue. Also attached the screen-shot for the issue.

Attachments (5)

config.js (839 bytes) - added by Senthil 8 years ago.
replacebycode.html (3.0 KB) - added by Senthil 8 years ago.
Safari_issue.JPG (53.5 KB) - added by Senthil 8 years ago.
4237.patch (1.8 KB) - added by Tobiasz Cudnik 8 years ago.
4237_2.patch (1.4 KB) - added by Tobiasz Cudnik 8 years ago.

Download all attachments as: .zip

Change History (16)

Changed 8 years ago by Senthil

Attachment: config.js added

Changed 8 years ago by Senthil

Attachment: replacebycode.html added

Changed 8 years ago by Senthil

Attachment: Safari_issue.JPG added

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

comment:2 Changed 8 years ago by Garry Yao

Component: GeneralUI : Toolbar
Keywords: Confirmed HasTest added
Priority: HighNormal

The key step of reproducing this bug is to config toolbar items in the custom config file.
Ticket test added with [4103] at : source:CKEditor/trunk/_test/tt/4237/4237.html

comment:3 Changed 8 years ago by Tobiasz Cudnik

Keywords: Webkit added
Owner: set to Tobiasz Cudnik
Status: newassigned

Confirming also on Safari4 and Chromium. Kama skin is also affected.

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4237.patch added

comment:4 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added

comment:5 Changed 8 years ago by Senthil

I have applied and tested the patch#4237 but it didn't fix the issue reported. Please let me know.

comment:6 Changed 8 years ago by Senthil

After applying this patch, when i am in arabic language and selecting the maximize button makes the edior disappear. Also the reported problem is not resolved by this patch.

Fred: This is a critical issue for us, pleas give high priority to fix this issue.

comment:7 Changed 8 years ago by Senthil

To produce the new issue follow the below steps:

  1. Apply this patch(4237.patch).
  2. Open the editor in IE 7/8 and put the cursor inside the editor area( cursor should be after the first charector in the editor area).
  3. Now select the maximize control, editor will be disappeard.

comment:8 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review- added; Review? removed
Priority: NormalHigh

Changed 8 years ago by Tobiasz Cudnik

Attachment: 4237_2.patch added

comment:9 in reply to:  7 Changed 8 years ago by Tobiasz Cudnik

Keywords: Review? added; Review- removed

Second patch targets safari3, which has a bit other issue then safari4.

Replying to Senthil:

To produce the new issue follow the below steps:

  1. Apply this patch(4237.patch).
  2. Open the editor in IE 7/8...

It would be strange that this patch is causing issue on non-webkit browser, as it's restricted to apply new css rules only for webkit browsers. Can you confirm that this issue does not exist without this patch ?

After following your steps i was unable to reproduce the second issue on IE8 (AR lang, quirks / strict). By "select the maximize control" you mean click or mouseover ?

comment:10 Changed 8 years ago by Garry Yao

Keywords: Review+ added; Review? removed

@Senthil: I don't see the editor disappearing issue you reported about IE, if you think it still exist, please open new ticket for it.

comment:11 Changed 8 years ago by Tobiasz Cudnik

Resolution: fixed
Status: assignedclosed

Fixed with [4159].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy