Opened 9 years ago

Closed 7 years ago

#4373 closed Bug (invalid)

All image caption deleted in mediawiki

Reported by: Karsten Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc: susanad.ramos

Description

All image captions (explaining titels of the pictures) are deleted in Mediawiki when using FCKeditor. I can write captions with the richt text editor or without. after saving they are displayed once alright. But doing any edit at the same page (even without changing anything) and save again, the captions disapear (also in the wikitext). I'm using MediaWiki 1.15.1, PHP 5.2.10 (cgi), MySQL 5.0.81-log. FCK-version 2.6.4.1, Build 23187. my webmaster says it's a bug in the parser. If there is there any help, please with very exact description.

Attachments (1)

Caption deleted.zip (387.3 KB) - added by Karsten 9 years ago.
screenshots

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by Karsten

Attachment: Caption deleted.zip added

screenshots

comment:1 Changed 9 years ago by Tim Carfrey

Priority: NormalHigh

I have a same issue. I am using 1.15.1 and fck-version 2.6.5.

It happens with any embedding.

we found it removes the embedding from the image. For example if you add an image with wikieditor with this code:

[[Image:myfile.jpg|left|150px]]

then open it in FCKeditor and save it with or without editing the page. The code will change to this:

[[Image:myfile.jpg]]

I feel this is a major issue and show be looked at ASAP.

I run Mediawiki on Windows and a on Linux and on both instances this happens.

comment:2 Changed 9 years ago by Carlos

I also have this issue here with Mediawiki 1.15.1, php 5.2.9, MySQL 5.0.67, FCK 2.6.4 build 21629. Here it keeps all image attributes, but *always* removes the captions. If it is not fixed we will probably not use the editor at all :(

Just writing here to give one more opinion about the urgency I see in it.

If I put:

[[Image:myfile.jpg|thumb|left|150px|Image caption]]

with or without the rich editor, and save, it saves like this:

[[Image:myfile.jpg|thumb|left|150px]]

Also tested with other image modes, like "frame", with the same result.

The thing that makes its priority higher is that the user may not change anything, if it only opens the page for editing and save, the editors corrupts the page itself.

I will try to look at the code, but don't know if I'll have the skill to correct this.

comment:3 in reply to:  description Changed 9 years ago by Alexander389

Replying to Karsten:

Same issue here. I am using Turnkey Linux MediaWiki Appliance 2009.10. Installed version of MediaWiki: 1.15.1

Wikitext becomes corrupted when switching between standard editor and rich editor.

[[Image:test.jpg]] becomes [[Image:]]

This is a major issue because even the image-links written in WikiText in standard editor become corrupted when switching to rich editor.

However this bug does not occur in the fckeditor sandbox.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Component: GeneralProject : MediaWiki+FCKeditor
Priority: HighNormal

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

#5180 has been marked as DUP.

comment:6 Changed 9 years ago by Tim Carfrey

Priority: NormalHigh

I can see how this is not a high issue as it has to do with the exact thing FCKeditor was created for.

Is someone going to look into this issue. 6 months is a long time for an issue that can be reproduced in multiple installs acrossed mutliple platforms.

comment:7 Changed 9 years ago by susanad.ramos

Cc: susanad.ramos added
Keywords: Color Button Align Button added

This has to do with the Color and Align Buttons.

Yesterday I removed the comments on both those lines in the FCKeditor_config.js file and this bug started hapenning. Today I commented again both lines and the bug no longer happens, the captions are correcty saved and don't desappear when someone re(edits) the article.

Hope this will help someone solve the bug because these buttons would'be most welcome.

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Color Button Align Button removed

comment:9 Changed 9 years ago by filburt

Removing the color and the align buttons does not work for me. But I figured out that the captions are only killed if the picture has the special type thumbnail or frame.

I'm using MW 1.16alpha and the latest FCKeditor Extension.

Any idea? Thanks for support! Filburt

comment:10 Changed 8 years ago by tidewater

Pasting in info from #3482, if these are considered duplicate issues then I'll leave it to ticket admins to determine whether to close:


Through some trial and error found that the following inclusion in LocalSettings.php of MediaWiki was causing the images to disappear on our system when switching in/out of rich text mode:

$wgUseTidy = true;

Commenting out this line resulted in the images no longer being lost. There is discussion on the following page about $wgUseTidy and configuration files although I'm not sure if this is a final solution that allows it to be enabled.

http://www.mediawiki.org/wiki/Manual_talk:$wgUseTidy

comment:11 Changed 8 years ago by jnolan

There's a workaround for this (pretty major) issue here: http://mediawiki.fckeditor.net/index.php/FCKeditor_integration_guide

It's about two-thirds of the way down, search for "caption". It will duplicate alt-text for screen readers, but that's a small price to pay to get captions back.

comment:12 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

MediaWiki and FCKEditor are no longer supported. Closing the ticked as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy