Ticket #4397 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Ambiguous page scroll

Reported by: tobiasz.cudnik Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: Firefox Confirmed Review+ Cc: batch2k@…, lens@…

Description

Ticket migrated from forum thread.

I have several CKEditor windows on a single page; they are invoked by a simple "ckeditor" style selector. Unexpectedly, after all plugin instances get initialized, page spontaneously scrolls to the lowest editor window (not smooth scrolling but a single-jump).

Reported to be FF only issue.

Attachments

4397.patch (673 bytes) - added by garry.yao 5 years ago.
4397_2.patch (2.7 KB) - added by garry.yao 5 years ago.

Change History

comment:1 Changed 5 years ago by batch2k

  • Cc batch2k@… added

comment:2 Changed 5 years ago by lens

  • Cc lens@… added

comment:3 Changed 5 years ago by garry.yao

  • Keywords Confirmed added
  • Status changed from new to assigned
  • Owner set to garry.yao
  • Milestone set to CKEditor 3.1

Ticket Test added at : http://ckeditor.t/tt/4397/1.html.

Changed 5 years ago by garry.yao

comment:4 Changed 5 years ago by garry.yao

  • Keywords Review? added

The design mode/contenteditable in FF is the culprit which cause host page scrolling.

comment:5 Changed 5 years ago by tobiasz.cudnik

  • Keywords Review+ added; Review? removed

Firefox 3.5 is not affected (at least linux version).

comment:6 Changed 5 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

I think all linux version is not affected ;).
Fixed with [4219].

comment:7 Changed 5 years ago by batch2k

I downloaded updated file (plugins/wysiwygarea/plugin.js, zip-file) from the ticket page. Well, this seems not working as well :-( Maybe I did something wrong and chosen incorrect file or something?..

Windows/FF 3.5

comment:8 Changed 5 years ago by alfonsoml

#4372 has been marked as dup

comment:9 Changed 5 years ago by garry.yao

  • Status changed from closed to reopened
  • Keywords Review+ removed
  • Resolution fixed deleted

The previous diagnose is wrong because it's actually a regression of [3816], where the key simulation cause the page to scroll, that hack should actually been moved somewhere else.

Changed 5 years ago by garry.yao

comment:10 Changed 5 years ago by garry.yao

  • Keywords Review? added

The committed changes will be reverted once this patch is accepted.

comment:11 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

Please fix the code indentation before committing, and include the changelog entry for it.

comment:12 Changed 5 years ago by garry.yao

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed with [4295].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy