Opened 8 years ago

Closed 7 years ago

#4459 closed Bug (fixed)

CKEditor maximized appears below select element in IE6

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Toolbar Version: 3.1
Keywords: Confirmed Review+ Cc: gogobu@…

Description

To reproduce, add

<select name="foo"><option value="bar">bar</option></select>

above

<label for="editor1">

in replacebycode sample.

In IE6 when CKEditor is maximized, select box appears above CKEditor. It works correctly in FF or IE8 (select box is invisible and only there is only CKEditor on the whole screen).

Attachments (3)

4459.patch (987 bytes) - added by Garry Yao 7 years ago.
4459_2.patch (2.6 KB) - added by Garry Yao 7 years ago.
4459_3.patch (2.9 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by Michael Bu

Cc: gogobu@… added
Milestone: CKEditor 3.2
Version: 3.1

Hope this could be fixed soon as most of our users are still on IE6.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3

Changed 7 years ago by Garry Yao

Attachment: 4459.patch added

comment:3 Changed 7 years ago by Garry Yao

Component: GeneralUI : Toolbar
Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

We're free of bug in v2 because of the implicit iframe shim. It's a shame that we still have to work on this in 2010 after IE6's funeral.

comment:4 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

Besides <select> also plugins can leak through a div, so the solution is to use a shim iframe (also for the dialog cover).

Taking into account the problem with flash movies, maybe the iframe should be generated for all the browsers?

Changed 7 years ago by Garry Yao

Attachment: 4459_2.patch added

comment:5 Changed 7 years ago by Garry Yao

Keywords: Review? added; Review- removed

I'm providing a patch here, but it sometimes crash the browser for me, not sure if it's only happened in my IE6.

comment:6 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

Please, don't use CSS expressions as they are known to have a very poor performance. And if it has crashed the browser in a few tests, you can be sure that people that use the editor everyday with IE6 will face the crash, so that must be fixed before requesting review. Having a <select> in the middle of the editor is ugly, having a crash means that all my data has been lost.

Changed 7 years ago by Garry Yao

Attachment: 4459_3.patch added

comment:7 Changed 7 years ago by Garry Yao

Keywords: Review? added; Review- removed

You're right but I'm not sure whether the crash problem is caused by CSS expressions, anyway let's try in another more unobtrusive way.

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:9 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5392].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy